Back to overview
Degraded
Microsoft and Minecraft authentication server outages
Oct 29 at 03:18pm CDT
Affected services
Litsl Proxy
Survival
Practice
Hub-01
Hub-02
Resolved
Oct 29 at 03:44pm CDT
Mojang Authentication Servers Are Partially Back Online All Services Should Be Fully Back Online In Around 30 Minutes
Affected services
Updated
Oct 29 at 03:26pm CDT
Minecraft Authentication Servers Are Currently Recovering
Affected services
Created
Oct 29 at 03:18pm CDT
The entire internet is having some issues at the moment. (Causing Mojang authentication servers to be down) Be patient there's nothing we can do.
Affected services